IU233 Community
This community supports discussion about information specific to IU233.

We strongly recommend Google Traslate function from Chrome browser to touch the latest information of our Japanese community site. Click Japan flag above and traslate it by the browser!

IU233 + RaspberryPi-0 W by Azertymon

Hello,
I am using a Rapsberry Pi-0 W, under 2017-07-05 jessie. (I've also tried with 2018-06-27 Stretch, the results are similar).
When I'm using the Vision Processing Framework or directly the SSP library, bugs occured:
> Only 2 frames (sometimes more, sometimes less) are send via the callback function, but after that nothing.
> Quitting the software is impossible without killing it.
> After this, the initialization of the camera communication don't begin.

Do you have any ideas why?
Do you need more explanation about the code I've used ?

Note: I don't have any problem with the raspberry 3B

Re: by yamagiwa

Hi,

I confirmed that the combination below works well.
2018-06-27 Stretch + SSL1.30 + VPF1.05

It is hard to know your situation without the system details.

Please report the following issues;
a) Modification of Config.txt
b) revision of RasPi Zero
c) OS version
d) SSP library version
e) VFP version
f) if sample apps of SSP do not work, the command lines of the executions
g) Profile file to be applied
h) IU233's colow model (BW or Color)
i) any other apps working other than the SSP related commands

Re: by Azertymon

Thank you for your answer and your confirmation.
So I guess, somewhere, there is a problem in the configuration I have and I will try to solve this.

The camera is the IU233 color model.
The configuration I spent the most time on was:
A Raspi zero (W) running 2017-07-05 jessie with SSP 1.26 and VPF 1.04.
(At the beginning I was working on used 2018-06-27 Stretch with SSP1.30 and VPF 1.05 and quickly tried by downgrading the OS to 2017-11-29 Stretch with SSP1.29 and VPF 1.05, but the results weren't any different)
Which revisions or config.txt modification are you interested in ? I don't think I made awkward modifications though.

To describe more:
None of the samples are working: they are compiling and running, but only send a few frames before the callbacks functions stop being called.
The profiles I am trying to load are the followings:
* - "Profiles/256x200@240Hz.xml"
* - "Profiles/640x480@60Hz.xml"
* - "Profiles/640x400@60Hz_bin.xml"
* - "Profiles/640x400@120Hz_bin.xml"
But it just for the glory of testings because only the 640x480 or 640x400 really matter.

In the configuration settings of the SSP library, I'm using:
From
p_settings.lib_settings.NumFrameFIFOSize = 16;
p_settings.lib_settings.NumThreadForBuildInPreprocess = 4;
to
p_settings.lib_settings.NumFrameFIFOSize = 2;
p_settings.lib_settings.NumThreadForBuildInPreprocess = 0;

I've noticed that using a higher number of FIFO frames change the number of frames I received before the bug. (The number of threads, doesn't change anything).

I am currently thinking that I may have a GPU/CPU memory allocation trouble. What allocation is it recommended to use?
Also the raspberry zero w only have 1 core, thus if some 'busy wait' are used, it may bother the entire application.

The VPF application is suffering of the same troubles, so I haven't played with it too much.

Anyway, if you confirm that Raspberry Pi Zero W + IU233 can work, I just have to try harder !

Re: by yamagiwa

Hi Azertymon,


I have tried your combination and tried the same situation by;
2017-07-05 jessie with SSP 1.26 and VPF 1.04

Unfortunately, it works well on my ZeroW...

Would you try it again form clean install following the Faq page?
https://www.visionproc.org/IU233_usage.php

Please do not forget take a memo during the settings.
If not working, I would like to refer your setting steps.